The incident is now resolved, X (Twitter) followers are available as usual.
Posted Feb 29, 2024 - 06:21 UTC
Identified
Since 02/17/24 at 7 pm UTC, X (Twitter) followers have not been updated in the API. Historical values are still available. Our deepest apologies for the inconvenience; we are working on this issue and will update you once it is solved.
Posted Feb 22, 2024 - 09:04 UTC
This incident affected: Website, Application, and API.